Website Maintenance
Incident Report for Frenalytics
Resolved
The Frenalytics website and Help Center are now available again following maintenance.
Posted Apr 24, 2021 - 20:07 EDT
Investigating
The Frenalytics website and Help Center are temporarily unavailable right now as we perform maintenance. The Frenalytics web app is not affected. You can continue to login at https://beta.frenalytics.com while our site is down for maintenance. Support requests can still be submitted via email at support@frenalytics.com.
Posted Apr 24, 2021 - 16:58 EDT
This incident affected: Frenalytics Website (Help Center, Frenalytics Website) and Frenalytics Web App, API.