FrenalyticsEDU Onboarding Experience is Currently Unavailable
Incident Report for Frenalytics
Resolved
We've fixed the issues in our onboarding experience that caused certain parts to not display correctly. Thank you for your patience!

For more help getting started with FrenalyticsEDU, visit our Learning Center, send an email to support@frenalytics.com, or contact us via live chat.
Posted Sep 07, 2023 - 14:50 EDT
Identified
We've identified an issue with our onboarding experience for FrenalyticsEDU and are actively working on a fix. This issue does not affect your ability to use FrenalyticsEDU in any way. For help with getting started with FrenalyticsEDU, visit our Learning Center, send an email to support@frenalytics.com, or contact us via live chat.
Posted Sep 06, 2023 - 14:40 EDT
This incident affected: Frenalytics Web App.